This post is based on wordpress powered website errors

After updating wordpress core software and few other plugins the dropdown menu started not working while in admin mode.

The dropdown had no issues while website is viewed in normal usermode.

Screenshot of dropdown menu in normal mode:

usermode

Screenshot of dropdown menu in admin mode:

adminmode

By above screenshots one can deduce that when pointer is on the menu item, which has child items, shows dropdown in user mode(Site viewed without any login) but not in admin mode(Site viewed after admin login).

The errors shown in Javascript console of chrome dev tools:

adminmode

These errors are arising due to different jquery versions used by theme and plugins the solution is to update the jquery version of theme as all plugins are already updated.

Which version of jquery to be used?

At the moment of writing this article two versions of jQuery is being maintained by jQuery.org, one supporting all browsers and the other not supporting Internet Explorer 6, 7, or 8.

jQuery 1.10.2 supports all browsers

jQuery 2.0.3 doesnt support Internet Explorer 6, 7, or 8

Decided to use jQuery 1.10.2 for now.

Downloaded jQuery 1.10.2 and replaced it with previous version in wordpress theme folder.

Now with this the usermode dropdown also stopped working.

For migrating code written using earlier jQuery versions to latest jQuery version we need add jQuery migrate script to the site.

After adding jQuery migrate script dropdown menus started appearing both in admin mode and usermode and all related js errors disappeared.